Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 02, 2026 - 05:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 18, 2026 - 17:18 UTC
Scheduled
The Enghouse team will be performing maintenance on the during the following time:
Maintenance Start: Tuesday, June 2, 2026, 5:00 a.m. UTC Maintenance End: Tuesday, June 2, 2026, 10:00 a.m. UTC
What are we changing?
We will be deploying the latest Hotfix Patches to bring the Toronto Node to the latest available CCaaS Software level. These patches will include updates for Agent UI, Admin, Admin Point, and various fixes for backend services.
More details can be found here: Release notes
How will this impact me? / Important update information
Our team will take every precaution to carry out this work in the background and minimize any impact. However, during the maintenance window there may be times when end users may get disconnected while backend services are being worked on. In these cases, users should be able to reconnect and continue working without issue.
A new Enghouse UI Agent client will be deployed. This update focuses on look, feel, and usability. Please contact Enghouse Support if you would like this enabled for your tenant.