CCaaS EMEA Node Emergency Maintenance Notification June 8 2026

Incident Report for Enghouse CCaaS

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 07:24 UTC

Investigating

The Enghouse team will be performing emergency maintenance on the EMEA CCaaS node during the following time:

Maintenance Start: Monday, June 8 2026, 10:00 p.m. UTC
Maintenance End: Monday, June 8 2026, 11:59 p.m. UTC

What are we changing?
IVR maintenance.

How will this impact me?
There may be some impact to active calls during the mainternance window

Do I need to do anything?
No action needed

What fixes are being applied to the platform?
Updating IVR settings to address reported delays.

If you have further questions, please reach out to Enghouse support here:

πŸ“ž Tel: +44 (0)203 357 3001
πŸ”— Customer Service Portal: Customer Portal
🌐 Web: www.enghouseinteractive.co.uk
πŸ“„ Customer Support Quick Reference Guide: Quick Ref Guide
πŸ“Š Status Page: Go to the CCaaS status page
Posted Jun 08, 2026 - 16:48 UTC
This incident affected: EMEA (EMEA - Voice, EMEA - Chat, EMEA - Email, EMEA - Callback, EMEA - Voicemail).