Investigating Performance Degradation EMEA Region

Incident Report for Enghouse CCaaS

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 08:40 UTC

Monitoring

A fix has been deployed for the issue impacting login and voice in EMEA Node, and we are monitoring the results.

Services should now be operating normally. We will continue to monitor and confirm resolution shortly.

Kind regards,
The Enghouse Cloud Team

πŸ“ž Tel: +44 (0)203 357 3001
πŸ”— Customer Service Portal: Customer Portal
🌐 Web: www.enghouseinteractive.co.uk
πŸ“„ Customer Support Quick Reference Guide: Quick Ref Guide
πŸ“Š Status Page: Go to the CCaaS status page
Posted Dec 01, 2025 - 13:30 UTC

Update

We are continuing to investigate this issue.
Posted Dec 01, 2025 - 10:57 UTC

Investigating

We are currently investigating an issue affecting the ability to Login and Outbound calls in the EMEA environment. Users may experience degraded performance when trying to connect to the UI or Intermittent outbound call issues.

Our engineering team is working to identify the root cause.

Thank you for your patience.

Kind regards,
The Enghouse Cloud Team

πŸ“ž Tel: +44 (0)203 357 3001
πŸ”— Customer Service Portal: Customer Portal
🌐 Web: www.enghouseinteractive.co.uk
πŸ“„ Customer Support Quick Reference Guide: Quick Ref Guide
πŸ“Š Status Page: Go to the CCaaS status page
Posted Dec 01, 2025 - 10:56 UTC
This incident affected: EMEA (EMEA - Login, EMEA - Voice).